New Posts New Posts RSS Feed - Z3 starter Motor
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

Z3 starter Motor

 Post Reply Post Reply
Author
ZGreen View Drop Down
Club Member
Club Member
Avatar

Joined: 25 Oct 2015
Location: Northants
Status: Offline
Points: 45
Post Options Post Options   Thanks (0) Thanks(0)   Quote ZGreen Quote  Post ReplyReply Direct Link To This Post Topic: Z3 starter Motor
    Posted: 09 Apr 2017 at 11:13am
Just had a new Water Pump, Thermostat fitted to my 1.9 Z3 1997, much to my surprise on its return from the Garage the starter tried to engage and then came out of mesh, The engine is now running considerably hotter than before as the stat was faulty. let it cool down starts fine as it always had.
I felt it was over advanced when hot and firing back throwing the starter out of mesh, but apparently its the starter, new one coming on Monday. I always seem to open a can of worms everytime I get a few jobs done as I can afford it there is always something else lurking waiting to pounce. I have had the car 18 months now and think repairs have cost me about £2,000 for a 1000 miles sunny day motoring .
I am trying to get the car into top condition but they were all jobs that really did need doing. Full dealer service records to 80,000 miles done 102,000 when I bought with service and other details for the intervening time. So if your looking to buy a Z do your research very very thoroughly. Trouble I really love it despite its trials and tribulations. Only thing I can think is the extra underbonnet temperature is perhaps expanding the Starter slightly causing probably stuck brushes from making good contact. Anybody else had experience of this kind. It really does get hot under the bonnet but temperature  gauge reads as it should. Should have tried a lump of wood and a hammer :D as it had only just come back from the garage thought i should return it straight away Confused.
Back to Top
Sponsored Links
BMW Car Club Forum Homepage

Back to Top
ZGreen View Drop Down
Club Member
Club Member
Avatar

Joined: 25 Oct 2015
Location: Northants
Status: Offline
Points: 45
Post Options Post Options   Thanks (0) Thanks(0)   Quote ZGreen Quote  Post ReplyReply Direct Link To This Post Posted: 19 May 2017 at 7:14pm
New starter appears to have cured the problem, but the really hot weather has not returned since. Had to top up the cooling system a couple of times in 80 odd miles, hope its air still working its way out Smile. I have re bled it a couple of times. and the top hose feels full of water.




Edited by ZGreen - 19 May 2017 at 7:20pm
Back to Top
safe1 View Drop Down
Club Member
Club Member
Avatar
BMWCC Club President

Joined: 09 Aug 2006
Status: Offline
Points: 1425
Post Options Post Options   Thanks (0) Thanks(0)   Quote safe1 Quote  Post ReplyReply Direct Link To This Post Posted: 23 May 2017 at 5:26pm
Trust problems are solved--Photo is a credit to all the care and attention given over the past.Hope You will come along to the next--June-- Earls Barton Meeting, on your doodstep---so we can appreciate the condition--
Gofastsafe
Back to Top
ZGreen View Drop Down
Club Member
Club Member
Avatar

Joined: 25 Oct 2015
Location: Northants
Status: Offline
Points: 45
Post Options Post Options   Thanks (0) Thanks(0)   Quote ZGreen Quote  Post ReplyReply Direct Link To This Post Posted: 23 May 2017 at 9:29pm
May well do John,brought it down last year, but brought my E30 320i convertible on the last occasion.
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 11.10
Copyright ©2001-2017 Web Wiz Ltd.

This page was generated in 0.078 seconds.